H3C华三S7506E系列交换机万兆IRF堆叠虚拟化

一、目前主流的网络虚拟化技术

思科虚拟交换系统VSS

思科虚拟交换系统VSS就是一种典型的网络虚拟化技术,它可以实现将多台思科交换机虚拟成单台交换机,使设备可用的端口数量、转发能力、性能格都倍增。

华为集群交换机系统CSS

CSS(Cluster Switch System,即集群交换机系统),它是网络虚拟化的一种形态,它同样可实现把多台支持集群的交换机链接起来,从而组成一台更大的交换机。

H3C IRF网络虚拟化技术

IRF(Intelligent Resilient Framework,智能弹性架构)是H3C自主研发的软件虚拟化技术。它的核心思想是将多台设备通过IRF物理端口连接在一起,进行必要的配置后,虚拟化成一台“分布式设备”。使用这种虚拟化技术可以实现多台设备的协同工作、统一管理和不间断维护。 为了便于描述,这个“虚拟设备”也称为IRF。所以,本文中的IRF有两层意思,一个是指IRF技术,一个是指IRF设备。

IRF主要具有以下优点:
简化管理
IRF形成之后,用户通过任意成员设备的任意端口都可以登录IRF系统,对IRF内所有成员设备进行统一管理。
高可靠性
IRF的高可靠性体现在多个方面,例如:IRF由多台成员设备组成,Master设备负责IRF的运行、管理和维护,Slave设备在作为备份的同时也可以处理业务。一旦Master设备故障,系统会迅速自动选举新的Master,以保证业务不中断,从而实现了设备的1:N备份;此外,成员设备之间的IRF链路支持聚合功能,IRF和上、下层设备之间的物理链路也支持聚合功能,多条链路之间可以互为备份也可以进行负载分担,从而进一步提高了IRF的可靠性。
强大的网络扩展能力
通过增加成员设备,可以轻松自如的扩展IRF的端口数、带宽。因为各成员设备都有CPU,能够独立处理协议报文、进行报文转发,所以IRF还能够轻松自如的扩展处理能力。

二、IRF的应用

 

  • 如图 所示,Master和Slave组成IRF,对上、下层设备来说,它们就是一台设备——IRF。IRF可部署在核心层、汇聚层和接入层。

 

《H3C华三S7506E系列交换机万兆IRF堆叠虚拟化》

三、S7506E IRF调试步骤

最近有个项目接触到两台S7506E用2 个万兆口实现 IRF 功能。现将大致的调试步骤记录下:
下图为某企业部分网络拓扑图

《H3C华三S7506E系列交换机万兆IRF堆叠虚拟化》

S7506E_CoreA配置步骤:

[S7506E_CoreA]irf member 1 #配置IRF的成员号为1;
[S7506E_CoreA]irf member 1 priority 32 #修改IRF 成员的优先级为32,CoreA选举为Master;
[S7506E_CoreA]irf auto-update enable #使能启动文件自动加载;
[S7506E_CoreA]interface Ten-GigabitEthernet 2/0/1
[S7506E_CoreA- ten 2/0/1]shutdown #需要先提前关闭物理口,IRF 逻辑口要绑定物理口;
[S7506E_CoreA]interface Ten-GigabitEthernet 2/0/2
[S7506E_CoreA- ten 2/0/2]shutdown
[S7506E_CoreA]irf-port 1/1 #创建IRF端口1/1并绑定设备的IRF端口和物理端口
[S7506E_CoreA- irf-port 1/1]port group interface Ten-GigabitEthernet 2/0/1
[S7506E_CoreA- irf-port 1/1]port group interface Ten-GigabitEthernet 2/0/2
[S7506E_CoreA]interface Ten-GigabitEthernet 2/0/1
[S7506E_CoreA- ten 2/0/1]undo shutdown #开启端口
[S7506E_CoreA]interface Ten-GigabitEthernet 2/0/2
[S7506E_CoreA- ten 2/0/2]undo shutdown
[S7506E_CoreA]save #保存配置,敲下一条命令后设备会重启;
[S7506E_CoreA]chassis convert mode irf #将设备切换到 IRF模式,设备会自动重启。

S7506E_CoreB配置步骤:

[S7506E_CoreB]irf member 2 #配置IRF的成员号为2,默认优先级选举为Slave;
[S7506E_CoreB]irf auto-update enable #使能启动文件自动加载;
[S7506E_CoreB]interface Ten-GigabitEthernet 2/0/1
[S7506E_CoreB- ten 2/0/1]shutdown #需要先提前关闭物理口,IRF 逻辑口要绑定物理口;
[S7506E_CoreB]interface Ten-GigabitEthernet 2/0/2
[S7506E_CoreB- ten 2/0/2]shutdown
[S7506E_CoreB]irf-port 2/2 #创建IRF端口2/2并绑定设备的IRF端口和物理端口
[S7506E_CoreB- irf-port 2/2]port group interface Ten-GigabitEthernet 2/0/1
[S7506E_CoreB- irf-port 2/2]port group interface Ten-GigabitEthernet 2/0/2
[S7506E_CoreB]interface Ten-GigabitEthernet 2/0/1
[S7506E_CoreB- ten 2/0/1]undo shutdown #开启端口
[S7506E_CoreB]interface Ten-GigabitEthernet 2/0/2
[S7506E_CoreB- ten 2/0/2]undo shutdown
[S7506E_CoreB]save #保存配置,敲下一条命令后设备会重启;
[S7506E_CoreB]chassis convert mode irf #将设备切换到 IRF模式,设备会自动重启。
注:
设备重启完成,其中一台S7506E上做配置更改,会自动同步到另外一台,可以把两台S7506E看作一台设备,并注意接口的逻辑对应关系。
S7506E_CoreA上的物理端口Ten-GigabitEthernet 2/0/1会变成Ten-GigabitEthernet 1/2/0/1
S7506E_CoreB上的物理端口Ten-GigabitEthernet 2/0/1会变成Ten-GigabitEthernet 2/2/0/1
[S7506E_CoreA] display current-configuration #部分配置信息
#
irf mac-address persistent always
irf auto-update enable
undo irf link-delay
irf member 1 priority 32
#
ip ttl-expires enable
ip unreachables enable
#
irf-pbr enable
switch-mode route-normal
#
irf-port 1/1
port group interface Ten-GigabitEthernet1/2/0/1 mode normal
port group interface Ten-GigabitEthernet1/2/0/2 mode normal
#
irf-port 2/2
port group interface Ten-GigabitEthernet2/2/0/1 mode normal
port group interface Ten-GigabitEthernet2/2/0/2 mode normal
#

BFD链路检测IRF心跳线配置步骤:

[S7506E_CoreA]Vlan 4000 #创建用于心跳检测的VLAN
[S7506E_CoreA]interface Vlan-interface4000 #创建用于心跳检测的VLAN虚拟接口
[S7506E_CoreA] description **IRF_BFD** #增加描述
[S7506E_CoreA] mad bfd enable #使能BFD链路检测
[S7506E_CoreA] mad ip address 1.1.1.1 255.255.255.252 member 1 #配置Member1 MAD IP
[S7506E_CoreA] mad ip address 1.1.1.2 255.255.255.252 member 2 #配置Member2 MAD IP
注意:MAD IP不能与其他接口IP地址相同,不能在Vlan-interface1接口下使能BFD MAD检测功能。

[S7506E_CoreA]interface GigabitEthernet1/4/0/28
[S7506E_CoreA] port link-mode bridge
[S7506E_CoreA] port access vlan 4000
[S7506E_CoreA] stp disable #因为BFD MAD和STP功能互斥,关闭STP协议。

[S7506E_CoreA]interface GigabitEthernet2/4/0/28
[S7506E_CoreA] port link-mode bridge
[S7506E_CoreA] port access vlan 4000
[S7506E_CoreA] stp disable #因为BFD MAD和STP功能互斥,关闭STP协议。
使用网线将S7506E_CoreA和S7506E_CoreB的28口连接起来。

四、配置链路聚合

 

  • S7506E与S5120之间必须做链路聚合,否则会产生环路。

 

核心交换机配置步骤:

将S7506E_CoreA和S7506E_CoreB上的物理端口GigabitEthernet3/0/1做逻辑链路聚会绑定。
[S7506E_CoreA]interface Bridge-Aggregation1 #创建链路聚会组1
[S7506E_CoreA-Bridge-Aggregation1]quit
[S7506E_CoreA]interface GigabitEthernet1/3/0/1 #S7506E_CoreA上的端口
[S7506E_CoreA-GigabitEthernet1/3/0/1]port link-aggregation group 1
[S7506E_CoreA-GigabitEthernet1/3/0/1]quit
[S7506E_CoreA]interface GigabitEthernet2/3/0/1 #S7506E_CoreB上的端口
[S7506E_CoreA-GigabitEthernet2/3/0/1]port link-aggregation group 1 #绑定到链路聚合组1
[S7506E_CoreA-GigabitEthernet2/3/0/1]quit
[S7506E_CoreA]interface Bridge-Aggregation1
[S7506E_CoreA-Bridge-Aggregation1]port link-type trunk #配置Trunk
[S7506E_CoreA-Bridge-Aggregation1]undo port trunk permit vlan 1
[S7506E_CoreA-Bridge-Aggregation1]port trunk permit vlan 2 to 4094
[S7506E_CoreA-Bridge-Aggregation1]quit
[S7506E_CoreA]save #保存配置

汇聚交换机配置步骤:

[S5120]interface Bridge-Aggregation1 #创建链路聚会组1
[S5120-Bridge-Aggregation1]quit
[S5120]interface GigabitEthernet1/0/51 #上行到S7506E_CoreA
[S5120-GigabitEthernet1/0/51]port link-aggregation group 1 #绑定到链路聚合组1
[S5120-GigabitEthernet1/0/51]quit
[S5120]interface GigabitEthernet1/0/52 #上行到S7506E_CoreB
[S5120-GigabitEthernet1/0/52]port link-aggregation group 1
[S5120-GigabitEthernet1/0/52]quit
[S5120]interface Bridge-Aggregation1
[S5120-Bridge-Aggregation1]port link-type trunk #配置Trunk
[S5120-Bridge-Aggregation1]undo port trunk permit vlan 1
[S5120-Bridge-Aggregation1]port trunk permit vlan 2 to 4094
[S5120-Bridge-Aggregation1]quit
[S5120]save #保存配置

五、常用IRF基本维护命令

显示IRF中所有成员设备的相关信息
display irf
查看IRF的拓扑信息
display irf topology
显示本IRF中所有成员设备的预配置信息
display irf configuration
显示MAD配置信息
display mad [verbose]
点赞
  1. 初入茅庐说道:

    我有两台7506e做了IRF 那我业务设备应该接到哪一个7506啊

    1. Cinwell说道:

      两台7506E看做成一台逻辑设备!你的业务设备支持冗余的话分别接两台,如果没有,两台接其中任何一台就行!

      1. 初入茅庐说道:

        如果分别将A和B交换机的端口a加入聚合组1 那我连接上一层防火墙时是要将两台物理机的a端口都插入上一层防火墙的聚合端口吗 打算做聚合通向防火墙

        1. Cinwell说道:

          是的,需要做链路聚合才能达到冗余的效果。不做聚合插两根线是环路!

  2. Cfyindq说道:

    请问下,两台7506做了虚拟化,下面接的是5120,想把其中一台7506向下接的光线移到另一台7506上,怎么做

    1. Cinwell说道:

      直接移啊 两台7506做了虚拟化 就是一台设备了!注意端口的逻辑关系。

发表评论

电子邮件地址不会被公开。 必填项已用*标注